User Guide


Skip to end of metadata
Go to start of metadata



DataExport

DataExport allows you to export entire databases or segments of databases into a text file and save that text file on the MarketWide host server. You can select specific fields, apply filters, and change the layout of the exported text file. You can also use DataExport in combination with Scheduler to regularly export text files. You can then use OutputManager to transfer the text file to your local client computer.

Topics:

Getting Started with DataExport

The DataExport module includes a new interface to make using DataExport even easier. You can access the Export Data module either from the MarketWide main window or from SQLManager. Below are five simple steps for running DataExport. More detailed steps can be found later in this section.

Simple Steps to Run a DataExport Report

  1. Open DataExport from the MarketWide main window.
  2. Select a database and table with SQLManager, or build a query.
  3. Select your formatting, either delimited, fixed width, XML, or table.
  4. Choose the destination of your text file, save the file, and then save the DataExport report file for later use if you wish.
  5. Indicate if you would like to "Show Expressions" and click Submit. Open the DataExport after processing to download the text file to your local machine if necessary.

You can enter DataExport in two ways:

  • From the MarketWide main window, choose Tools > Modules > Data Export.
  • In SQLManager, highlight the databases you want to use and then choose Tools > Data Export, or right click on the database and choose Data Export.

Creating a New DataExport from MarketWide Main Window 

When you enter the DataExport module, you first must select either a table or build a query. Make sure that you are creating a new export, and then click the SQLManager button on the toolbar to select the database and table you wish to export. Once a table is selected, the "Current Table" blue text at the bottom of the DataExport dialog will display the name of your table, including server and realm information. If no table has been selected, the Current Table will say nothing.

To Create a New DataExport Report and Text File

  1. Open the DataExport module by clicking the () DataExport button on the MarketWide main window toolbar.
  2. Click on either Choose a Table or Build a Query.
  3. A preview of your table's formatting is now shown in the bottom area of the DataExport dialog. You may change the order of elements of your table with the blue arrows located on the toolbar.
  4. Determine if a filter is needed. If so, click the Filter button on the toolbar to create one.
  5. Next, simply work from left to right through each column at the top. Determine the formatting of the text file under the File Options column. If you would like to use a delimited format, be sure to select the "delimited" button. The default is fixed width. Specify your delimited file options if necessary and move to the next column to the right titled Output.
  6. Here you select the destination for your delimited, fixed width, XML, or Table file. Simply click on the ellipses button to the right of the text field to navigate to the saved location of your choice. Title your new file and click Save.
  7. If you wish to save your DataExport report file for later use or scheduling, go to File > Save, title your report, and click Save.
  8. Click the Submit () button on the toolbar. DataExport will close, and the MarketWide main window will display the file's status.
  9. When the process is completed, double-click the DataExport on the MarketWide main window to view your results and download the text file to your local machine if necessary. To download, click the download button.

Note

  • Continuing in DataExport without choosing a table will force MarketWide to use the default table as previously selected. You can change the default table by entering SQLManager and double-clicking a table. This table stays as the default even if MarketWide is closed. Even if DataExport says that no table has been selected, the default table will be used. All results from DataExport will be based on the default table.
  • If you wish to preview your results before saving, click the Preview button in the toolbar.

Editing DataExport Layouts 

Once you have chosen the data that you wish to export to a text file, you are able to edit the layout of that text file. You can choose to export data in delimited or fixed width format and the order of the export data from the top portion of the DataExport window. 

  • Delimited – Export data is placed into delimited format, which is recognized by most spreadsheet programs, including Microsoft Excel. If delimited format is chosen, certain other options are available.
  • Delimiters – Chooses the character that delimits between columns (i.e. comma).
  • Text Qualifier – Chooses the text qualifier (if any) that will separate text in your exported text file (i.e. quotations).
  • Field Names as First Row – Creates column headers for the export file based on the field names from your database.
  • Fixed Width – Export data is placed into fixed width format.
  • XML - Export data is placed into XML format.
  • Table - Export data is placed into table format.
  • File Format - This allows the user to edit specific segments of the DataExport format. This is based on what information you wish to export as previously chosen in QueryBuilder as well as the format you wish to export in (delimited or fixed width).
  • Source Name - The name of the data field as chosen in QueryBuilder, this value cannot be changed.
  • Source Type - The type of data in the data field, this value cannot be changed.
  • Source Size - The length of data values within the field, this value cannot be changed.
  • Target Name - The title heading as it will appear in the exported text file. By default, this has the same name as the Source Name, but can be changed to whatever the user wishes.
  • Target Size – The number of characters that will be displayed in the exported text file. This value is, by default, the number of characters of a data value. However, this value can be changed to something other than the default. For example, if a Customer ID is 8 characters long, you can change the Target Size to 4 and only display the first four numbers of the ID. This option is only available in fixed width format, and not in delimited format.
  • Start – The number of characters in a row when the data will begin to be displayed. This option cannot be changed, but rather is based on Target Size. Changing the Target Size to a larger number will cause the data to be displayed later in the column.


Time Saver

You can click the headings of each heading in the File Format dialog to highlight the entire column. You can then order the table by clicking the Sort Ascending or Sort Descending buttons, or by right-clicking and choosing Sort.

Note

  • You can use the blue up/down arrows to change the order of the data fields as they will appear in the text file. You can also click on the number of each field and drag them to the order that you wish.
  • You can add blank filler rows (for readability) by right-clicking in the File Format dialog and choosing Add Row. You can also delete rows by right-clicking and choosing Delete Row.

Creating a Filter in DataExport

While you could export every customer within a database, you might wish to limit your population, and filter out certain people for a more accurate campaign. For example, you might want to only export a list of customers who have spent over $500 dollars and who allow mailing. While it is not necessary to use filters in DataExport, it will allow you to focus your campaign. The filter dialog is identical to others used throughout the MarketWide suite.


Specifying Host Server Destination

There is one final step in DataExport. You can choose to save not only the DataExport text file, but the query file as well. This saves time if there are changes to make to a query. You can also use these files in conjunction with Scheduler, and export the data regularly. For more information on using Scheduler, see the "Scheduler Dialog" portion of this manual.

Saving DataExport Output

DataExport allows you to easily select a location to save your DataExport's output in the form of a delimited or fixed width text file. You can specify where on the MarketWide host you wish to save your DataExport text file, as well as specify FTP settings if you choose. To select the save location for your text file, click on the ellipses (  ) button on the right side of the Output portion of the DataExport window. You can type in the file path, or simply use Windows Explorer to navigate to your file destination.

New Report File versus Saved Report File 

One useful feature of DataExport is the option to save DataExport report files for future use. There are several reasons to save report files. If you have certain data that you wish to export regularly, you can save the report file and then use the report file with Scheduler to automatically export your files at a specified time. You can also make changes to a report file later, such as adding or deleting fields that you wish to export, or changing the filters.

Saving DataExport Reports for Future Use

DataExport also provides you the capability to save the DataExport report file itself, thus saving you the time of creating it, or a similar one, again in the future. By navigating to File > Save, you can easily specify where on the MarketWide host you wish to save your DataExport report file. By saving the report publicly, multiple users can share the same report file. 

The DataExport report file is the layout file for the DataExport text file that you just set up. By saving the DataExport query file, you can quickly make changes to your DataExport later. Scheduler can also use a saved DataExport query file to run a DataExport at a time of your choice. For more information on DataExport report files, see "New Report File Versus Saved Report File." To save your DataExport query file, make sure to click Save prior to exiting DataExport.

If you do not wish to run the query right away, you can save the DataExport query file instead of running the query. For instance, if you are waiting for more customer data, you will want to wait before running the query. You can also run the query immediately and save the DataExport query file. Once DataExport has run the query, you can see the results at the path where you specified the DataExport text file to be saved.

Creating a New DataExport from SQLManager 

If you wish to export an entire database, rather than simply segments of it, there is an alternate method to use DataExport. You can enter DataExport from SQLManager. Every field in the database will be automatically selected, eliminating the need to use QueryBuilder. Or, if you are already in SQLManager, you can access DataExport without having to go back to the MarketWide main window. 

To Choose a Database from SQLManager

There are three ways to use DataExport within SQLManager:

  1. Highlight a database, then go to Tools > Export Data.
  2. Right-click on a database and choose Export Data.
  3. Highlight a database, then click the () icon.

Once a database has been chosen in SQLManager, you will not need to enter QueryBuilder, as every field in the database will be exported. From here, you can create filters and continue with DataExport.

DataExport Menu and Toolbar

The DataExport toolbar provides quick access to commonly used commands in the DataExport main window. Click the icon once to carry out the action represented by that icon.

Icon

Description

Menu Equivalent

Creates a new DataExport.

File > New

Opens a saved DataExport report.

File > Open

Saves your current DataExport report.

File > Save

Allows you to select how and where the report is saved.

File > Save As

Opens the saved report on your local machine.

File > Local > Open

Saves the open report to your local machine.

File > Local > Save

Submits your report to the database.

File > Submit

Gives a preview of the DataExport report before it is printed.

File > Preview

Prints your table fields and their corresponding information.

File > Print

Schedules the DataExport report in the Scheduler.

File > Schedule

Opens the Properties for the currently selected item.

File > Properties

Exits out of the DataExport module.

File > Exit


Copies the selected cell(s).

Edit > Copy

Pastes the contents of the clipboard into the selected cell.

Edit > Paste

Removes the currently selected row

Edit > Delete

Moves the selected row up.

Edit > Move Up

Moves the selected row down.

Edit > Move Down

Opens SQLManager.

Edit > SQLManager

Opens QueryBuilder.

Edit > QueryBuilder

Opens the Filter dialog.

Edit > Filter

Displays help information for the DataExport program.

Help > DataExport Help