User Guide


Skip to end of metadata
Go to start of metadata

PackageManager gives the ability to run multiple tasks in a sequential order. Suppose it is necessary to run a TouchPoint and then immediately run an Analyzer report on the consumers selected in that TouchPoint. This is achieved efficiently in a package.

Simply create a package that has the TouchPoint report and the Analyzer report immediately following. You can manually run the package to execute your task in the order you entered them into the PackageManager or you can use the Scheduler to run the package at a future date.

Topics:

Getting Started with PackageManager

Running a group of tasks one by one can be a tedious process. PackageManager saves valuable time by giving the possibility to run multiple tasks as a solitary group. PackageManager starts by running the task at the top and then consecutively running through the list. TouchPoints, SendEx, Analyzer, Exports and External Processes can be added into the PackageManager.

To Use PackageManager

  1. Drag and drop the Report node and select a task from the given list (Analyzer, Export, SendEx, TouchPoint, or an external process).
  2. Repeat to select another task.
  3. If you would like the package to continue to run regardless of whether it encounters an error, select the Continue on Error check box.
  4. View the tasks by clicking "Open Query" on the bottom right of the desired task.
  5. Swap a task with another task by clicking "Change Query" on the bottom left of the desired task.
  6. To delete an item right-click and select remove.
  7. Put the tasks in the order you would like them to run by both selecting the task and dragging it to the desired position or by selecting the task and using the up and down arrows to navigate it.
  8. To submit the package, click the green submit button. ()

Note

PackageManager runs the task in the ordered listed, so placement of the tasks is important.

Item Properties Dialog

This dialog appears when a new task is added. The options may be different depending on the type of task. Below is a list of all the options along with their descriptions.

    • Title – This is where a name can be applied to the selected task inside of PackageManager. It does not have to be the saved name of the task. If a name is not created, then one is generated for you.
    • Report – The name of the saved report.
    • The open folder icon () – Opens the Open Report dialog to retrieve a saved report.
    • Edit Description – Changes name of your report within PackageManager (the original task name is kept in parentheses).   
    • Continue on Error – Tells the package to continue running even if it encounters an error in one of the tasks.
    • Change Query  Allows you to select a different task for a report. 
    • Open Query – Opens the selected task in your report to review or make changes. 

The PackageManager Menu and Toolbar

The toolbar provides quick access to commonly used commands in PackageManager. Click the icon once to carry out the action.

Icon

Description

Menu Equivalent

Creates a new PackageManager.

File > New

Opens a saved PackageManager report.

File > Open

Saves your current PackageManager report.

File > Save

Allows you to select how and where the report is saved.

File > Save As


Opens the saved report on your local machine.

File > Local > Open

Saves the open report to your local machine.

File > Local > Save

Prints the layout of all actions in the PackageManager.

File > Print

Submits a PackageManager.

File > Submit

Checks if the package is valid.

File > Validate

Schedules the package in the Scheduler.

File > Schedule

Opens the Properties for the currently selected item.

File > Properties

--

Exits out of PackageManager module.

File > Exit

Removes a selected item from the list.

Edit > Remove

Clears all the current tasks in the current package.

Edit > Clear

Moves the highlighted item up one spot in the list.

Edit > Move Item Up

Moves the highlighted item down one spot in the list.

Edit > Move Item Down

Puts the PackageManager workflow in a horizontal view.

View > Orientation > Horizontal

Puts the PackageManager workflow in a vertical view.

View > Orientation > Vertical

Zooms in on the PackageManager workflow.

View > Zoom > Zoom In

Zooms out on the PackageManager workflow.

View > Zoom > Zoom Out

Adjusts the current PackageManager workflow view to fit the screen.

View > Zoom > Zoom To Fit

Adjusts the current PackageManager workflow view to 100% aspect ratio on the screen.

View > Zoom > 100%

Displays help information for the PackageManager program.

Help > Package Manager Help