User Guide


Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.





To use this feature, administrative permissions must be given. True to its name, TableEdit gives the ability to edit database tables. Editing can be done by adding, deleting, or changing the current data. This can be especially useful when modifying "lookup" tables.

Tip
titleTo Use Table Edit
  1. First select a table in SQL Manager.
  2. Click the refresh () button to see the data currently in the table.
  3. To add a row of data, click the Add Record () button in the toolbar or right click on a cell and select the Add Record option.
  4. Data can now be added to the new row, simply by selecting a cell and typing in the data
  5. To edit any existing data, click on the cell containing the data and type in the new information.
  6. To delete a row of data, highlight the whole row and click the Delete Record button () in the toolbar or right click and select the delete record option.
  7. To save your changes and exit out of the TableEdit program click the save button
    (
Note
titleNote

Any included media files can be viewed by right clicking on the cell and selecting the open reference option.

Anchor
TableEditToolbar
TableEditToolbar

The TableEdit Menu and Toolbar

Icon

Description

Menu Equivalent

Commits the changes to the table.

File > Save  

Prints the table fields and their corresponding information.

File > Print

Refreshes the current table.

File > Refresh
 

--

Exits out of the TableEdit module.

File > Exit

Allows you to sequentially undo up to the last 20 actions.

Edit > Undo

Allows you to sequentially redo up to the last 20 actions.

Edit > Redo

Cuts the highlighted cells.

Edit > Cut

Copies the highlighted cells.

Edit > Copy

--

Copies the highlighted cells and their headers.

Edit > Copy with Headers

Pastes the contents of the clipboard into the selected cell.

Edit > Paste

Clears all the new data.

Edit > Clear

--

Selects all the columns and rows.

Edit > Select All

Toggles descriptions on and off.

Data > Toggle Descriptions

Shows the next page of results.

Data > Next

Adds a row to the currently selected table.

Data > Add Record

Removes a row to the currently selected table.

Data > Delete Record

Opens the fill window, and sets all rows in the column to the fill value.

Data > Fill

Sorts the currently displayed segments in ascending order.

Data > Sort Ascending

Sorts the currently displayed segments in descending order.

Data > Sort Descending

--

Gives detailed information about the selected cell

Data > Drilldowns

Opens SQLManager.

Tools > SQLManager

Opens the filter window

Tools > Filter

--

Opens the selected media file.

Tools > Open Reference

--

Displays help information for the TableEdit program.

Help > TableEdit Help