The MarketWide Main Window consists of four main components: The Menu and Toolbar, Current Task Panes, Tasks and Queries List, and the Status Bar. This area covers the basic essentials of MarketWide and gives an understanding of how these functions operate. 

Topics:

The MarketWide Main Window

Option

Description

Menu and Toolbar

The MarketWide menu provides access to various commands and options. The toolbar provides quick mouse access to many of the more frequently used commands and features. You can see the name of each toolbar button in a tool tip, which displays when you point at (not click on) the button. You may also add modules and applications to the toolbar from the Tools menu.

Archive Pane

The Archive Pane is a convenient place to save completed tasks. When a task is completed it can be moved to the Archived folder to be revisited or rerun later. Storing tasks in this folder frees up memory space on the server, allowing the system to run faster. Folders can also be created inside the Archive folder; which makes organizing a multitude of completed tasks simple.

Current, Email and System Task Panes

This list displays reports, campaigns or email tasks you have running or have ran. The task list displays the report name, type of MarketWide report, whether it is a scheduled item, the date and time you ran it, and its completion status (Pending, Complete, Error, etc.). You can open running queries or completed reports by double-clicking on the task in the task list, and you can also cancel running tasks from the task list. If System Tasks are enabled, you can also view the status of various System Tasks. Additionally, active queries are listed here, which include QueryBuilder queries, AdHoc queries, viewing table contents, and drill-downs.

Status Bar

The status bar indicates whether you are connected to the server, which server you're connected to, and your user name. You can also see how many active queries, open applications, and tasks appear in your MarketWide session.  

Multiple Connections

If you have work in more than one MarketWide realm it can be tedious to do work in one and then log out and change over to another realm. MarketWide resolves this by providing the capability to be logged into two realms simultaneously.

After logging into both realms, you can simply switch between the realms by switching tabs. The main window will change to reflect the new realm and whatever permissions you have in it. Through this, you can have modules from both realms open at once. For example, a TouchPoint can run from the first realm while simultaneously running an Analyzer from the second. When you want to log out of one of the realms, simply click the 'x' on the tab next to the realm name.

  1. After logging in to the first realm, select the add connection button () to the left and above the tasks pane.
  2. Select the realm, and enter your username and password.
  3. Click Connect.

To have the realm name displayed on any modules you open, select the Display Realm Name in Caption in the Options dialog.

Active Applications

Active Applications are open modules of MarketWide programs, such as TouchPoint, SendEx, SQLManager, QueryBuilder, or Analyzer, or the results of a completed task. You cannot exit MarketWide if you have any active applications.

The Active Applications Dialog 

The Active Applications dialog allows you to view any MarketWide applications that are currently running. From Active Applications, you can shut down an application or switch to another Active application.

You can access the Active Applications dialog using the Tools > Active Applications menu option in the main window or by clicking on the Active Applications link on the status bar at the bottom right of the main window.

Applications listed in the Active Applications dialog are posted in reverse order from the order in which they were opened; i.e., the most recently opened applications are on top.

Active Applications contains the following options:

    • Information – Displays any active applications.
    • Shut Down – Exits the highlighted program without saving changes.
    • Switch To – Changes view from one active application to another.
    • Close – Closes the Active Applications dialog.
    • Help – Displays information about the Active Applications dialog.

You can access this dialog by going to Tools > Active Applications or by clicking Active Applications on the status bar.

You can terminate an application from this dialog by highlighting it, then clicking Shut Down. The application will close without saving. Simply click Close when finished to exit the Active Applications window.

The Switch To option allows you to change to another application by highlighting it and clicking Switch To. The selected program then becomes the active application.

The MarketWide Active Queries List

Active queries return results without using an application module. They are a single instance of a report and therefore are deleted after viewing unless the criteria or results are saved. You can view queries in the main pane of the MarketWide main window. Active queries are displayed in this pane while running or when their results are open. When you close a query's results window, the active query automatically disappears.

Active queries are displayed on the MarketWide Main Window below the queries task group. Queries remain here after running until opened for viewing. Once a query is viewed, it is removed from the task list. You may save the results of your query or save the criteria of the query to be run again later.

You can cancel active queries by highlighting the active query in the main MarketWide window and choosing Edit > Cancel Task from the menu in the MarketWide main window.

You can also cancel active queries by right-clicking the active query and choosing Cancel from the pop-up menu.

The MarketWide Catalog

MarketWide uses a catalog to preserve information about databases, tables, and the field names each server requires. This catalog is stored on the MarketWide Host and is accessed every time MarketWide is launched.

The System Administrator can also change the catalog through the MarketWide Administration Utility. When an Administrator changes the catalog, all users receive an alert. When you see this alert, close all MarketWide applications and click the Refresh Catalog icon on the toolbar or select File > Refresh Catalog.

  1. Close all open MarketWide applications such as TouchPoint, SendEx, HTML Editor, SQLManager, QueryBuilder or Analyzer.
  2. If changes to the catalog have been made, MarketWide will alert you and provide you the option to refresh it. In the MarketWide main window, click Refresh Catalog on the toolbar or go to Tools > Refresh Catalog. The catalog will update. Note that the option to refresh the catalog is only available if a refresh is necessary.
  1. To download a fresh catalog, regardless of whether an update has occurred, close any open MarketWide modules and return to the MarketWide Main Window.
  2. From the MarketWide Main Window, navigate to Tools > Download Fresh Catalog.

To check for open applications, select Tools > Active Applications from the MarketWide main window.

Common MarketWide Main Window Functions

The MarketWide Main Window's main functions involve launching other modules and keeping track of reports and campaigns. However, there are several features within the MarketWide Main Window that allow you to configure your own MarketWide experience.

Editing User Settings

The User Settings dialog allows you to view and edit your MarketWide user account preferences. You can access the User Settings ( ) by selecting Tools in the MarketWide menu. Inside the User Settings, there are two sections: 

General
In the General tab, you will see options to enter in your name, email and mobile phone for alerts. There is also an option to Test SMS for verifying that your mobile phone can receive text messages.

Alerts
The Alerts tab gives you options of what type of system alerts you would like to receive and how you can be notified. You have the options of being notified by either email, SMS (text message) or Desktop (popup notification).

External Processes

An external process acts as an intermediary between MarketWide and an outside process. It enables a campaign to run and automatically update Facebook or Twitter, send out emails, and much more. An external process can be added to a package, giving you the ability to run a set of campaigns and then instantaneously market to the selected customers. See PackageManager for more information.

To run an external process, click on the external processes icon (  ) in the toolbar and select the desired process from the drop-down list. If there are no external processes available then the drop-down list will not appear.

  • To have external processes set up, please contact your MarketWide administrator.
  • To have the realm name displayed on any modules you open, select the Display Realm Name in Caption in the Options dialog

Adding and Removing Programs

The programs that appear on the programs toolbar of the MarketWide main window are maintained using the MarketWide Add/Remove Programs dialog. If you wish to run a program, it must first be configured in this dialog.

By default, the both the Analyzer and the TouchPoint programs are configured during MarketWide installation and appear automatically on the toolbar. Additional programs can also be added to the toolbar as well. The default programs included on the toolbar will vary with your MarketWide administrative privileges.

If you are the MarketWide administrator, you can make external programs available within MarketWide by placing shortcuts on the toolbar. For example, if you frequently save report output as an Excel spreadsheet, you may wish to add a button to the toolbar that opens Excel from within MarketWide.

The Add/Remove Programs dialog offers the following options:

    • Program Name – Displays the name of all the programs that are available to you. Programs are split into two types: standard programs such as Open report or Cancel Task, and applications such as SQLManager and Analyzer.
    • Program Title – Enables you to enter a program description. This description appears in a tool tip caption when the cursor is held over the program button.
    • Add – Adds the program name and program title information.
    • Insert Separator – Inserts a separator above the highlighted program.
    • Remove – Removes the highlighted program from the Programs area.
    • Move up – Moves the highlighted program up one space.
    • Move down – Moves the highlighted program down one space.
  1. Select Tools > Customize Toolbar from the menu in the MarketWide main window to bring up the Add/Remove Programs dialog.
  2. Click Add. You may select any executable file to add to the toolbar for easy access such as frequently used Microsoft Office applications.
  3. In the Program Title text box, enter a description of the program. This description appears in the Tools > Modules menu in the MarketWide main window and as a tool tip when pointing at the program's button on the toolbar.
  4. Click OK and verify the program's icon has appeared on the toolbar for use.
  1. Select Tools > Customize Toolbar from the menu in the MarketWide main window to bring up the Add/Remove Programs dialog.
  2. Highlight the program you wish to delete.
  3. Click Remove.
  4. Click OK.

You can also add programs to the tool bar that are not a MarketWide module. This can be helpful for programs such as Microsoft Excel that you may often access while using MarketWide. 

The MarketWide Options Dialog Box 

The Options dialog, accessed by clicking Tools > Options, allows you to set system settings, view the location of temporary files, and perform cleanups.

The Main Window Tab 

In the General portion of the options window, you can arrange system settings so that certain operations and functions take effect when you log on to MarketWide.

The Tasks Check Boxes 

    • Prompt to Save Untitled Tasks – Prompts to save an untitled task when you run it.
    • Prompt on Task Delete – Opens the Delete dialog to confirm data deletions.
    • Display Archive Notification - Receive a notice when a task in your main Window hits the archive date.

The General Check Boxes 

    • Show Aliases – Displays aliases for a specified field name when enabled. If selected, field names appear with aliases; if not, field names will appear with the names stored in the database. Aliases are set up by the administrator in the MarketWide Administration Utility. Talk to your MarketWide administrator for more information.
    • Display Realm Name in Caption - Displays the name of the realm at the top of the module. This is useful when you have multiple connections open at once.

The MarketWide Menu and Toolbar

The toolbar provides quick access to commonly used commands in the MarketWide main window. Click the icon once to carry out the action represented by that icon.

Please note that depending on how administrative privileges are set up, some icons may not be visible to you.

Menu Icons

Icon

Description

Menu Equivalent

Opens the Connect to Realm dialog and adds another tab.

File > Add Connection

Opens the MarketWide Login dialog for connecting to a Server.

File > Disconnect

Opens the Open Report dialog to retrieve a MarketWide report.

File > Open Report

Opens the Windows Explorer dialog to retrieve a MarketWide report.

File > Open Local Report

Gives detailed information about the selected items.

File > Drilldowns

Closes MarketWide. You must close all open applications before you exit MarketWide.

File > Exit

Selects all the tasks visible in the task pane.

Edit > Select All Tasks

Moves the selected task(s) to the Archive folder

Edit > Archive

Moves the selected task(s) out of the Archive folder.

Edit > Unarchive

Reruns the selected task.

Edit > Rerun Task

Restarts the selected task that was paused.

Edit > Resume Task

Pause the selected tasks.

Edit > Pause Task

Cancels a report from the task list. See Canceling Tasks for more information.

Edit > Cancel Task

Deletes the highlighted task in the task list. See Deleting Tasks for more information.

Edit > Remove Task

Opens the Query Properties dialog showing statistics for the highlighted task such as the SQL Trace and speed.

Edit > Properties

--

Opens the Adding and Removing Programs dialog to add, update, and delete programs.

Tools > Customize Toolbar

--

Opens the Active Applications dialog, which allows you to see all open and running applications.

Tools > Active Applications

Opens the TouchPoint Template Wizard.

Tools > Templates > TouchPoint Template Wizard

Opens the Solicit File Template Wizard.

Tools > Templates > Solicit Template Wizard

Opens the CubeBuilder dialog to create a cube.

Tools > CubeBuilder

Opens the Variable Builder dialog

Tools > Variable Builder

Refreshes the catalog when the System Administrator makes changes.

Tools > Download Catalog

Opens the User Settings dialog and goes to the General tab.

Tools > User Settings

Opens the User Settings dialog and goes to the Alerts tab.

Tools > Alerts

Opens the Change Password dialog, which allows you to edit password and change your email. 

Tools > Change Password

Shows the Options Dialog

Tools > Options

Accesses help information about the MarketWide main window.

Help > MarketWide Help

Displays technical information about MarketWide.

Help > About MarketWide



Toolbar Icons

Icon

Description

Opens the SQLManager application.

Opens the Output Manager application.  

Opens the Scheduler application.

Opens the PackageManager application.  

Opens the Analyzer application.

Opens the TouchPoint application.

Opens the TouchPoint Campaign Editor application.

Opens the QueryBuilder application.

Opens the DataExport application.

Opens the TableEdit application.

Opens the HTMLEditor application.

Opens the SendEx application.

Opens the CubeBuilder application.

Opens the External Process application.

Opens the AdminUtility application.